What’s Vulnerable › Vulnerabilities
CVE-2018-10852
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-26 · updated 2026-06-17
- Weakness: CWE-200
Description
The UNIX pipe which sudo uses to contact SSSD and read the available sudo rules from SSSD has too wide permissions, which means that anyone who can send a message using the same raw protocol that sudo and SSSD use can read the sudo rules available for any user. This affects versions of SSSD before 1.16.3.
Affected products
- Debian Linux: 8.0
- [UNKNOWN] sssd: before 1.16.3 — fixed in 1.16.3
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: [UNKNOWN] sssd 1.16.3. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104547
- https://access.redhat.com/errata/RHSA-2018:3158
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10852
- https://lists.debian.org/debian-lts-announce/2018/07/msg00019.html
- http://www.securityfocus.com/bid/104547
- https://access.redhat.com/errata/RHSA-2018:3158
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10852
- https://lists.debian.org/debian-lts-announce/2018/07/msg00019.html
Get alerted when CVE-2018-10852 or the next vulnerability affects your stack