What’s Vulnerable › Vulnerabilities
CVE-2018-10858
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-22 · updated 2026-06-17
- Weakness: CWE-20
Description
A heap-buffer overflow was found in the way samba clients processed extra long filename in a directory listing. A malicious samba server could use this flaw to cause arbitrary code execution on a samba client. Samba versions before 4.6.16, 4.7.9 and 4.8.4 are vulnerable.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 9.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
- RedHat Virtualization: 4.0
- RedHat Virtualization Host: 4.0
- Samba: before 4.6.16; from 4.7.0 before 4.7.9; from 4.8.0 before 4.8.4 — fixed in 4.6.16, 4.7.9, 4.8.4
How to fix
Upgrade to a fixed version: Samba 4.6.16, 4.7.9, 4.8.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105085
- http://www.securitytracker.com/id/1042002
- https://access.redhat.com/errata/RHSA-2018:2612
- https://access.redhat.com/errata/RHSA-2018:2613
- https://access.redhat.com/errata/RHSA-2018:3056
- https://access.redhat.com/errata/RHSA-2018:3470
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10858
- https://kc.mcafee.com/corporate/index?page=content&id=SB10284
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20180814-0001/
- https://usn.ubuntu.com/3738-1/
- https://www.debian.org/security/2018/dsa-4271
Get alerted when CVE-2018-10858 or the next vulnerability affects your stack