What’s Vulnerable › Vulnerabilities
CVE-2018-10871
- Severity: high (CVSS 7.2 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-18 · updated 2026-06-17
- Weakness: CWE-312
Description
389-ds-base before versions 1.3.8.5, 1.4.0.12 is vulnerable to a Cleartext Storage of Sensitive Information. By default, when the Replica and/or retroChangeLog plugins are enabled, 389-ds-base stores passwords in plaintext format in their respective changelog files. An attacker with sufficiently high privileges, such as root or Directory Manager, can query these files in order to retrieve plaintext passwords.
Affected products
- Debian Linux: 8.0
- Red Hat, Inc. 389-ds-base: before 1.3.8.5; from 1.4.0.0 before 1.4.0.12 — fixed in 1.3.8.5, 1.4.0.12
How to fix
Upgrade to a fixed version: Red Hat, Inc. 389-ds-base 1.3.8.5, 1.4.0.12. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2019:3401
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10871
- https://lists.debian.org/debian-lts-announce/2018/08/msg00032.html
- https://pagure.io/389-ds-base/issue/49789
- https://access.redhat.com/errata/RHSA-2019:3401
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10871
- https://lists.debian.org/debian-lts-announce/2018/08/msg00032.html
- https://pagure.io/389-ds-base/issue/49789
Get alerted when CVE-2018-10871 or the next vulnerability affects your stack