What’s Vulnerable › Vulnerabilities
CVE-2018-10873
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-17 · updated 2026-06-17
- Weakness: CWE-119
Description
A vulnerability was discovered in SPICE before version 0.14.1 where the generated code used for demarshalling messages lacked sufficient bounds checks. A malicious client or server, after authentication, could send specially crafted messages to its peer which would result in a crash or, potentially, other impacts.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0, 9.0
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- RedHat Virtualization: 4.0
- RedHat Virtualization Host: 4.0
- The SPICE Project spice: before 0.14.1 — fixed in 0.14.1
How to fix
Upgrade to a fixed version: The SPICE Project spice 0.14.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105152
- https://access.redhat.com/errata/RHSA-2018:2731
- https://access.redhat.com/errata/RHSA-2018:2732
- https://access.redhat.com/errata/RHSA-2018:3470
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10873
- https://gitlab.freedesktop.org/spice/spice-common/commit/bb15d4815ab586b4c4a20f4a565970a44824c42c
- https://lists.debian.org/debian-lts-announce/2018/08/msg00035.html
- https://lists.debian.org/debian-lts-announce/2018/08/msg00037.html
- https://lists.debian.org/debian-lts-announce/2018/08/msg00038.html
- https://usn.ubuntu.com/3751-1/
- https://www.debian.org/security/2018/dsa-4319
- http://www.securityfocus.com/bid/105152
Get alerted when CVE-2018-10873 or the next vulnerability affects your stack