What’s Vulnerable › Vulnerabilities
CVE-2018-10878
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-07-26 · updated 2026-06-17
- Weakness: CWE-787
Description
A flaw was found in the Linux kernel's ext4 filesystem. A local user can cause an out-of-bounds write and a denial of service or unspecified other impact is possible by mounting and operating a crafted ext4 filesystem image.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 8.0
- Linux kernel: before 3.16.58; from 3.17 before 3.18.124; from 3.19 before 4.4.140; from 4.5 before 4.9.112; from 4.10 before 4.14.55; from 4.15 before 4.17.6 — fixed in 3.16.58, 3.18.124, 4.14.55, 4.17.6, 4.4.140, 4.9.112
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 3.16.58, 3.18.124, 4.14.55, 4.17.6. Check the vendor advisory for mitigations.
References
- http://patchwork.ozlabs.org/patch/929237/
- http://patchwork.ozlabs.org/patch/929238/
- https://access.redhat.com/errata/RHSA-2018:2948
- https://access.redhat.com/errata/RHSA-2018:3083
- https://access.redhat.com/errata/RHSA-2018:3096
- https://bugzilla.kernel.org/show_bug.cgi?id=199865
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10878
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=77260807d1170a8cf35dbb06e07461a655f67eee
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=819b23f1c501b17b9694325471789e6b5cc2d0d2
- https://lists.debian.org/debian-lts-announce/2018/07/msg00020.html
- https://usn.ubuntu.com/3753-1/
- https://usn.ubuntu.com/3753-2/
Get alerted when CVE-2018-10878 or the next vulnerability affects your stack