What’s Vulnerable › Vulnerabilities
CVE-2018-10888
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-10 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in libgit2 before version 0.27.3. A missing check in git_delta_apply function in delta.c file, may lead to an out-of-bound read while reading a binary delta file. An attacker may use this flaw to cause a Denial of Service.
Affected products
- Debian Linux: 8.0, 9.0
- libgit2: before 0.27.3 — fixed in 0.27.3
How to fix
Upgrade to a fixed version: libgit2 0.27.3. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1598024
- https://github.com/libgit2/libgit2/commit/9844d38bed10e9ff17174434b3421b227ae710f3
- https://github.com/libgit2/libgit2/releases/tag/v0.27.3
- https://lists.debian.org/debian-lts-announce/2018/08/msg00024.html
- https://lists.debian.org/debian-lts-announce/2022/03/msg00031.html
- https://bugzilla.redhat.com/show_bug.cgi?id=1598024
- https://github.com/libgit2/libgit2/commit/9844d38bed10e9ff17174434b3421b227ae710f3
- https://github.com/libgit2/libgit2/releases/tag/v0.27.3
- https://lists.debian.org/debian-lts-announce/2018/08/msg00024.html
- https://lists.debian.org/debian-lts-announce/2022/03/msg00031.html
Get alerted when CVE-2018-10888 or the next vulnerability affects your stack