What’s Vulnerable › Vulnerabilities
CVE-2018-1089
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-09 · updated 2026-06-17
- Weakness: CWE-122
Description
389-ds-base before versions 1.4.0.9, 1.3.8.1, 1.3.6.15 did not properly handle long search filters with characters needing escapes, possibly leading to buffer overflows. A remote, unauthenticated attacker could potentially use this flaw to make ns-slapd crash via a specially crafted LDAP request, thus resulting in denial of service.
Affected products
- Debian Linux: 8.0
- Red Hat, Inc. 389-ds-base: from 1.3.6.0 before 1.3.6.15; from 1.4.0.0 before 1.4.0.9; 1.3.8.1, 1.3.8.2 — fixed in 1.3.6.15, 1.4.0.9
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Workstation: 6.0, 7.0
How to fix
Upgrade to a fixed version: Red Hat, Inc. 389-ds-base 1.3.6.15, 1.4.0.9. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/104137
- https://access.redhat.com/errata/RHSA-2018:1364
- https://access.redhat.com/errata/RHSA-2018:1380
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1089
- https://lists.debian.org/debian-lts-announce/2018/07/msg00018.html
- http://www.securityfocus.com/bid/104137
- https://access.redhat.com/errata/RHSA-2018:1364
- https://access.redhat.com/errata/RHSA-2018:1380
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1089
- https://lists.debian.org/debian-lts-announce/2018/07/msg00018.html
Get alerted when CVE-2018-1089 or the next vulnerability affects your stack