What’s Vulnerable › Vulnerabilities
CVE-2018-10895
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-12 · updated 2026-06-17
- Weakness: CWE-352
Description
qutebrowser before version 1.4.1 is vulnerable to a cross-site request forgery flaw that allows websites to access 'qute://*' URLs. A malicious website could exploit this to load a 'qute://settings/set' URL, which then sets 'editor.command' to a bash script, resulting in arbitrary code execution.
Affected products
- qutebrowser: before 1.4.1 — fixed in 1.4.1
How to fix
Upgrade to a fixed version: qutebrowser 1.4.1. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2018/07/11/7
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10895
- https://github.com/qutebrowser/qutebrowser/commit/43e58ac865ff862c2008c510fc5f7627e10b4660
- http://www.openwall.com/lists/oss-security/2018/07/11/7
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10895
- https://github.com/qutebrowser/qutebrowser/commit/43e58ac865ff862c2008c510fc5f7627e10b4660
Get alerted when CVE-2018-10895 or the next vulnerability affects your stack