What’s Vulnerable › Vulnerabilities
CVE-2018-1090
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-18 · updated 2026-06-17
- Weakness: CWE-200
Description
In Pulp before version 2.16.2, secrets are passed into override_config when triggering a task and then become readable to all users with read access on the distributor/importer. An attacker with API access can then view these secrets.
Affected products
- Fedoraproject Fedora: all versions
- [UNKNOWN] pulp: before 2.16.2 — fixed in 2.16.2
- Red Hat Satellite 6: 6.4
How to fix
Upgrade to a fixed version: [UNKNOWN] pulp 2.16.2. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:2927
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1090
- https://pulp.plan.io/issues/3521
- https://access.redhat.com/errata/RHSA-2018:2927
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1090
- https://pulp.plan.io/issues/3521
Get alerted when CVE-2018-1090 or the next vulnerability affects your stack