What’s Vulnerable › Vulnerabilities
CVE-2018-10903
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-30 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in python-cryptography versions between >=1.9.0 and <2.3. The finalize_with_tag API did not enforce a minimum tag length. If a user did not validate the input length prior to passing it to finalize_with_tag an attacker could craft an invalid payload with a shortened tag (e.g. 1 byte) such that they would have a 1 in 256 chance of passing the MAC check. GCM tag forgeries can cause key leakage.
Affected products
- Canonical Ubuntu Linux: 18.04
- Cryptography Python-Cryptography: from 1.9.0 before 2.3 — fixed in 2.3
- OpenStack: 13
How to fix
Upgrade to a fixed version: Cryptography Python-Cryptography 2.3. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:3600
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10903
- https://github.com/pyca/cryptography/pull/4342/commits/688e0f673bfbf43fa898994326c6877f00ab19ef
- https://usn.ubuntu.com/3720-1/
- https://access.redhat.com/errata/RHSA-2018:3600
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10903
- https://github.com/pyca/cryptography/pull/4342/commits/688e0f673bfbf43fa898994326c6877f00ab19ef
- https://usn.ubuntu.com/3720-1/
Get alerted when CVE-2018-10903 or the next vulnerability affects your stack