What’s Vulnerable › Vulnerabilities
CVE-2018-10908
- Severity: medium (CVSS 6.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-09 · updated 2026-06-17
- Weakness: CWE-20
Description
It was found that vdsm before version 4.20.37 invokes qemu-img on untrusted inputs without limiting resources. By uploading a specially crafted image, an attacker could cause the qemu-img process to consume unbounded amounts of memory of CPU time, causing a denial of service condition that could potentially impact other users of the host.
Affected products
- vdsm: before 4.20.37 — fixed in 4.20.37
- RedHat Virtualization: 4.0
How to fix
Upgrade to a fixed version: vdsm 4.20.37. Check the vendor advisory for mitigations.
References
- http://lists.nongnu.org/archive/html/qemu-block/2018-07/msg00488.html
- https://access.redhat.com/errata/RHEA-2018:2624
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10908
- https://gerrit.ovirt.org/#/c/93195/
- http://lists.nongnu.org/archive/html/qemu-block/2018-07/msg00488.html
- https://access.redhat.com/errata/RHEA-2018:2624
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10908
- https://gerrit.ovirt.org/#/c/93195/
Get alerted when CVE-2018-10908 or the next vulnerability affects your stack