What’s Vulnerable › Vulnerabilities
CVE-2018-10913
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-04 · updated 2026-06-17
- Weakness: CWE-209
Description
An information disclosure vulnerability was discovered in glusterfs server. An attacker could issue a xattr request via glusterfs FUSE to determine the existence of any file.
Affected products
- Debian Linux: 8.0, 9.0
- Red Hat glusterfs: from 3.12.0 before 3.12.14; from 4.1.0 before 4.1.8 — fixed in 3.12.14, 4.1.8
- openSUSE Leap: 15.1
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Virtualization Host: 4.0
How to fix
Upgrade to a fixed version: Red Hat glusterfs 3.12.14, 4.1.8. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00035.html
- https://access.redhat.com/errata/RHSA-2018:2607
- https://access.redhat.com/errata/RHSA-2018:2608
- https://access.redhat.com/errata/RHSA-2018:3470
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10913
- https://lists.debian.org/debian-lts-announce/2018/09/msg00021.html
- https://lists.debian.org/debian-lts-announce/2021/11/msg00000.html
- https://review.gluster.org/#/c/glusterfs/+/21071/
- https://security.gentoo.org/glsa/201904-06
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00035.html
- https://access.redhat.com/errata/RHSA-2018:2607
- https://access.redhat.com/errata/RHSA-2018:2608
Get alerted when CVE-2018-10913 or the next vulnerability affects your stack