What’s Vulnerable › Vulnerabilities
CVE-2018-10924
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-04 · updated 2026-06-17
- Weakness: CWE-400
Description
It was discovered that fsync(2) system call in glusterfs client code leaks memory. An authenticated attacker could use this flaw to launch a denial of service attack by making gluster clients consume memory of the host machine.
Affected products
- Red Hat glusterfs: from 3.12.11 before 3.12.14; from 4.0.0 before 4.1.4 — fixed in 3.12.14, 4.1.4
How to fix
Upgrade to a fixed version: Red Hat glusterfs 3.12.14, 4.1.4. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00035.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10924
- https://review.gluster.org/#/c/glusterfs/+/20723/
- https://security.gentoo.org/glsa/201904-06
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00035.html
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10924
- https://review.gluster.org/#/c/glusterfs/+/20723/
- https://security.gentoo.org/glsa/201904-06
Get alerted when CVE-2018-10924 or the next vulnerability affects your stack