What’s Vulnerable › Vulnerabilities
CVE-2018-10925
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-09 · updated 2026-06-17
- Weakness: CWE-863
Description
It was discovered that PostgreSQL versions before 10.5, 9.6.10, 9.5.14, 9.4.19, and 9.3.24 failed to properly check authorization on certain statements involved with "INSERT ... ON CONFLICT DO UPDATE". An attacker with "CREATE TABLE" privileges could exploit this to read arbitrary bytes server memory. If the attacker also had certain "INSERT" and limited "UPDATE" privileges to a particular table, they could exploit this to update other columns in the same table.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Debian Linux: 9.0
- PostgreSQL: from 9.5.0 before 9.5.14; from 9.6.0 before 9.6.10; from 10.0 before 10.5 — fixed in 10.5, 9.5.14, 9.6.10
How to fix
Upgrade to a fixed version: PostgreSQL 10.5, 9.5.14, 9.6.10. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- http://www.securityfocus.com/bid/105052
- http://www.securitytracker.com/id/1041446
- https://access.redhat.com/errata/RHSA-2018:2511
- https://access.redhat.com/errata/RHSA-2018:2565
- https://access.redhat.com/errata/RHSA-2018:2566
- https://access.redhat.com/errata/RHSA-2018:3816
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10925
- https://security.gentoo.org/glsa/201810-08
- https://usn.ubuntu.com/3744-1/
- https://www.debian.org/security/2018/dsa-4269
- https://www.postgresql.org/about/news/1878/
Get alerted when CVE-2018-10925 or the next vulnerability affects your stack