What’s Vulnerable › Vulnerabilities
CVE-2018-10936
- Severity: high (CVSS 8.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-30 · updated 2026-06-17
- Weakness: CWE-297
Description
A weakness was found in postgresql-jdbc before version 42.2.5. It was possible to provide an SSL Factory and not check the host name if a host name verifier was not provided to the driver. This could lead to a condition where a man-in-the-middle attacker could masquerade as a trusted server by providing a certificate for the wrong host, as long as it was signed by a trusted CA.
Affected products
- Postgresql Jdbc Driver: before 42.2.5 — fixed in 42.2.5
- Red Hat Enterprise Linux: 6.0, 7.0
How to fix
Upgrade to a fixed version: Postgresql Jdbc Driver 42.2.5. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105220
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10936
- https://lists.apache.org/thread.html/9317fd092b257a0815434b116a8af8daea6e920b6673f4fd5583d5fe%40%3Ccommits.druid.apache.org%3E
- https://www.postgresql.org/about/news/1883/
- http://www.securityfocus.com/bid/105220
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-10936
- https://lists.apache.org/thread.html/9317fd092b257a0815434b116a8af8daea6e920b6673f4fd5583d5fe%40%3Ccommits.druid.apache.org%3E
- https://www.postgresql.org/about/news/1883/
Get alerted when CVE-2018-10936 or the next vulnerability affects your stack