What’s Vulnerable › Vulnerabilities

CVE-2018-11047

Description

Cloud Foundry UAA, versions 4.19 prior to 4.19.2 and 4.12 prior to 4.12.4 and 4.10 prior to 4.10.2 and 4.7 prior to 4.7.6 and 4.5 prior to 4.5.7, incorrectly authorizes requests to admin endpoints by accepting a valid refresh token in lieu of an access token. Refresh tokens by design have a longer expiration time than access tokens, allowing the possessor of a refresh token to authenticate longer than expected. This affects the administrative endpoints of the UAA. i.e. /Users, /Groups, etc. However, if the user has been deleted or had groups removed, or the client was deleted, the refresh token will no longer be valid.

Affected products

How to fix

Upgrade to a fixed version: Cloud Foundry UAA 4.10.2, 4.12.4, 4.19.2, 4.5.7. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-11047 or the next vulnerability affects your stack