What’s Vulnerable › Vulnerabilities

CVE-2018-11058

Description

RSA BSAFE Micro Edition Suite, versions prior to 4.0.11 (in 4.0.x) and prior to 4.1.6 (in 4.1.x), and RSA BSAFE Crypto-C Micro Edition, version prior to 4.0.5.3 (in 4.0.x) contain a Buffer Over-Read vulnerability when parsing ASN.1 data. A remote attacker could use maliciously constructed ASN.1 data that would result in such issue.

Affected products

How to fix

Upgrade to a fixed version: Dell Bsafe 4.0.11, 4.1.6; Dell Bsafe Crypto-C 4.0.5.3; Oracle Corporation TimesTen In-Memory Database 18.1.4.1.0. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-11058 or the next vulnerability affects your stack