What’s Vulnerable › Vulnerabilities
CVE-2018-1106
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-23 · updated 2026-06-17
- Weakness: CWE-287
Description
An authentication bypass flaw has been found in PackageKit before 1.1.10 that allows users without administrator privileges to install signed packages. A local attacker can use this vulnerability to install vulnerable packages to further compromise a system.
Affected products
- Canonical Ubuntu Linux: 17.10
- Debian Linux: 9.0
- PackageKit: before 1.1.10 — fixed in 1.1.10
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Aus: 7.6
- RedHat Enterprise Linux Server Eus: 7.5, 7.6
- RedHat Enterprise Linux Server Tus: 7.6
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: PackageKit 1.1.10. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2018/04/23/3
- https://access.redhat.com/errata/RHSA-2018:1224
- https://bugzilla.redhat.com/show_bug.cgi?id=1565992
- https://usn.ubuntu.com/3634-1/
- https://www.debian.org/security/2018/dsa-4207
- http://www.openwall.com/lists/oss-security/2018/04/23/3
- https://access.redhat.com/errata/RHSA-2018:1224
- https://bugzilla.redhat.com/show_bug.cgi?id=1565992
- https://usn.ubuntu.com/3634-1/
- https://www.debian.org/security/2018/dsa-4207
Get alerted when CVE-2018-1106 or the next vulnerability affects your stack