What’s Vulnerable › Vulnerabilities
CVE-2018-1109
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2021-03-30 · updated 2026-06-17
- Weakness: CWE-185
Description
A vulnerability was found in Braces versions 2.2.0 and above, prior to 2.3.1. Affected versions of this package are vulnerable to Regular Expression Denial of Service (ReDoS) attacks.
Affected products
- nodejs-braces: before 2.3.1 — fixed in 2.3.1
How to fix
Upgrade to a fixed version: nodejs-braces 2.3.1. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=1547272
- https://snyk.io/vuln/npm:braces:20180219
- https://bugzilla.redhat.com/show_bug.cgi?id=1547272
- https://snyk.io/vuln/npm:braces:20180219
Get alerted when CVE-2018-1109 or the next vulnerability affects your stack