What’s Vulnerable › Vulnerabilities
CVE-2018-1112
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-04-25 · updated 2026-06-17
- Weakness: CWE-287
Description
glusterfs server before versions 3.10.12, 4.0.2 is vulnerable when using 'auth.allow' option which allows any unauthenticated gluster client to connect from any network to mount gluster storage volumes. NOTE: this vulnerability exists because of a CVE-2018-1088 regression.
Affected products
- Red Hat glusterfs: before 3.10.12; 4.0.2 — fixed in 3.10.12
How to fix
Upgrade to a fixed version: Red Hat glusterfs 3.10.12. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00035.html
- https://access.redhat.com/articles/3422521
- https://access.redhat.com/errata/RHSA-2018:1268
- https://access.redhat.com/errata/RHSA-2018:1269
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1112
- https://review.gluster.org/#/c/19899/1..2
- http://lists.opensuse.org/opensuse-security-announce/2020-01/msg00035.html
- https://access.redhat.com/articles/3422521
- https://access.redhat.com/errata/RHSA-2018:1268
- https://access.redhat.com/errata/RHSA-2018:1269
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1112
- https://review.gluster.org/#/c/19899/1..2
Get alerted when CVE-2018-1112 or the next vulnerability affects your stack