What’s Vulnerable › Vulnerabilities
CVE-2018-1115
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-10 · updated 2026-10-08
- Weakness: CWE-732
Description
postgresql before versions 10.4, 9.6.9 is vulnerable in the adminpack extension, the pg_catalog.pg_logfile_rotate() function doesn't follow the same ACLs than pg_rorate_logfile. If the adminpack is added to a database, an attacker able to connect to it could exploit this to force log rotation.
Affected products
- openSUSE Leap: 15.1
- PostgreSQL: before 9.6.9; from 10.0 before 10.4 — fixed in 10.4, 9.6.9
How to fix
Upgrade to a fixed version: PostgreSQL 10.4, 9.6.9. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- http://www.securityfocus.com/bid/104285
- https://access.redhat.com/errata/RHSA-2018:2565
- https://access.redhat.com/errata/RHSA-2018:2566
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1115
- https://git.postgresql.org/gitweb/?p=postgresql.git%3Ba=commitdiff%3Bh=7b34740
- https://security.gentoo.org/glsa/201810-08
- http://lists.opensuse.org/opensuse-security-announce/2020-08/msg00043.html
- http://www.securityfocus.com/bid/104285
- https://access.redhat.com/errata/RHSA-2018:2565
- https://access.redhat.com/errata/RHSA-2018:2566
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1115
Get alerted when CVE-2018-1115 or the next vulnerability affects your stack