What’s Vulnerable › Vulnerabilities
CVE-2018-1116
- Severity: medium (CVSS 4.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-07-10 · updated 2026-06-17
- Weakness: CWE-285
Description
A flaw was found in polkit before version 0.116. The implementation of the polkit_backend_interactive_authority_check_authorization function in polkitd allows to test for authentication and trigger authentication of unrelated processes owned by other users. This may result in a local DoS and information disclosure.
Affected products
- Canonical Ubuntu Linux: 12.04
- Debian Linux: 8.0
- Polkit Project Polkit: before 0.115 — fixed in 0.115
How to fix
Upgrade to a fixed version: Polkit Project Polkit 0.115. Check the vendor advisory for mitigations.
References
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1116
- https://cgit.freedesktop.org/polkit/commit/?id=bc7ffad5364
- https://lists.debian.org/debian-lts-announce/2018/07/msg00042.html
- https://security.gentoo.org/glsa/201908-14
- https://usn.ubuntu.com/3717-2/
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1116
- https://cgit.freedesktop.org/polkit/commit/?id=bc7ffad5364
- https://lists.debian.org/debian-lts-announce/2018/07/msg00042.html
- https://security.gentoo.org/glsa/201908-14
- https://usn.ubuntu.com/3717-2/
Get alerted when CVE-2018-1116 or the next vulnerability affects your stack