What’s Vulnerable › Vulnerabilities
CVE-2018-1120
- Severity: medium (CVSS 5.3 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-20 · updated 2026-06-17
- Weakness: CWE-122
Description
A flaw was found affecting the Linux kernel before version 4.17. By mmap()ing a FUSE-backed file onto a process's memory containing command line arguments (or environment strings), an attacker can cause utilities from psutils or procps (such as ps, w) or any other program which makes a read() call to the /proc/<pid>/cmdline (or /proc/<pid>/environ) files to block indefinitely (denial of service) or for some controlled time (as a synchronization primitive for other attacks).
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04
- Debian Linux: 8.0
- Linux kernel: before 4.17 — fixed in 4.17
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
- RedHat Virtualization Host: 4.0
How to fix
Upgrade to a fixed version: Linux kernel 4.17. Check the vendor advisory for mitigations.
References
- http://seclists.org/oss-sec/2018/q2/122
- http://www.securityfocus.com/bid/104229
- https://access.redhat.com/errata/RHSA-2018:2948
- https://access.redhat.com/errata/RHSA-2018:3083
- https://access.redhat.com/errata/RHSA-2018:3096
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1120
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=7f7ccc2ccc2e70c6054685f5e3522efa81556830
- https://lists.debian.org/debian-lts-announce/2018/07/msg00020.html
- https://security.gentoo.org/glsa/201805-14
- https://usn.ubuntu.com/3752-1/
- https://usn.ubuntu.com/3752-2/
- https://usn.ubuntu.com/3752-3/
Get alerted when CVE-2018-1120 or the next vulnerability affects your stack