What’s Vulnerable › Vulnerabilities
CVE-2018-11218
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 58.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-06-17 · updated 2026-06-17
- Weakness: CWE-787
Description
Memory Corruption was discovered in the cmsgpack library in the Lua subsystem in Redis before 3.2.12, 4.x before 4.0.10, and 5.x before 5.0 RC2 because of stack-based buffer overflows.
Affected products
- Debian Linux: 9.0
- Oracle Corporation Communications Operations Monitor: 3.4, 4.0
- OpenStack: 10, 13
- Redis Labs Redis: before 3.2.12; from 4.0 before 4.0.10; 5.0-rc1 — fixed in 3.2.12, 4.0.10
How to fix
Upgrade to a fixed version: Redis Labs Redis 3.2.12, 4.0.10. Check the vendor advisory for mitigations.
References
- http://antirez.com/news/119
- http://www.securityfocus.com/bid/104553
- https://access.redhat.com/errata/RHSA-2019:0052
- https://access.redhat.com/errata/RHSA-2019:0094
- https://access.redhat.com/errata/RHSA-2019:1860
- https://github.com/antirez/redis/commit/52a00201fca331217c3b4b8b634f6a0f57d6b7d3
- https://github.com/antirez/redis/commit/5ccb6f7a791bf3490357b00a898885759d98bab0
- https://github.com/antirez/redis/issues/5017
- https://raw.githubusercontent.com/antirez/redis/4.0/00-RELEASENOTES
- https://raw.githubusercontent.com/antirez/redis/5.0/00-RELEASENOTES
- https://security.gentoo.org/glsa/201908-04
- https://www.debian.org/security/2018/dsa-4230
Get alerted when CVE-2018-11218 or the next vulnerability affects your stack