What’s Vulnerable › Vulnerabilities
CVE-2018-1123
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 8.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-23 · updated 2026-06-17
- Weakness: CWE-122
Description
procps-ng before version 3.3.15 is vulnerable to a denial of service in ps via mmap buffer overflow. Inbuilt protection in ps maps a guard page at the end of the overflowed buffer, ensuring that the impact of this flaw is limited to a crash (temporary denial of service).
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- Procps-Ng Project Procps-Ng: before 3.3.15 — fixed in 3.3.15
How to fix
Upgrade to a fixed version: Procps-Ng Project Procps-Ng 3.3.15. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00059.html
- http://seclists.org/oss-sec/2018/q2/122
- http://www.securityfocus.com/bid/104214
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1123
- https://lists.apache.org/thread.html/r58af02e294bd07f487e2c64ffc0a29b837db5600e33b6e698b9d696b%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.apache.org/thread.html/rf4c02775860db415b4955778a131c2795223f61cb8c6a450893651e4%40%3Cissues.bookkeeper.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2018/05/msg00021.html
- https://security.gentoo.org/glsa/201805-14
- https://usn.ubuntu.com/3658-1/
- https://usn.ubuntu.com/3658-3/
- https://www.debian.org/security/2018/dsa-4208
Get alerted when CVE-2018-1123 or the next vulnerability affects your stack