What’s Vulnerable › Vulnerabilities
CVE-2018-1124
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-23 · updated 2026-06-17
- Weakness: CWE-122
Description
procps-ng before version 3.3.15 is vulnerable to multiple integer overflows leading to a heap corruption in file2strvec function. This allows a privilege escalation for a local attacker who can create entries in procfs by starting processes, which could result in crashes or arbitrary code execution in proc utilities run by other users.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- openSUSE Leap: 15.0, 15.1
- Procps-Ng Project Procps-Ng: before 3.3.15 — fixed in 3.3.15
- Red Hat Enterprise Linux: 6.0, 7.0, 7.5
- RedHat Enterprise Linux Desktop: 6.0, 7.0
- RedHat Enterprise Linux Server: 6.0, 7.0
- RedHat Enterprise Linux Workstation: 6.0, 7.0
- Schneider Electric StruxureWare Data Center Expert: before 7.6.0 — fixed in 7.6.0
How to fix
Upgrade to a fixed version: Procps-Ng Project Procps-Ng 3.3.15; Schneider Electric StruxureWare Data Center Expert 7.6.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00059.html
- http://seclists.org/oss-sec/2018/q2/122
- http://www.securityfocus.com/bid/104214
- http://www.securitytracker.com/id/1041057
- https://access.redhat.com/errata/RHSA-2018:1700
- https://access.redhat.com/errata/RHSA-2018:1777
- https://access.redhat.com/errata/RHSA-2018:1820
- https://access.redhat.com/errata/RHSA-2018:2267
- https://access.redhat.com/errata/RHSA-2018:2268
- https://access.redhat.com/errata/RHSA-2019:1944
- https://access.redhat.com/errata/RHSA-2019:2401
Get alerted when CVE-2018-1124 or the next vulnerability affects your stack