What’s Vulnerable › Vulnerabilities
CVE-2018-1125
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-23 · updated 2026-06-17
- Weakness: CWE-121
Description
procps-ng before version 3.3.15 is vulnerable to a stack buffer overflow in pgrep. This vulnerability is mitigated by FORTIFY, as it involves strncat() to a stack-allocated string. When pgrep is compiled with FORTIFY (as on Red Hat Enterprise Linux and Fedora), the impact is limited to a crash.
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- openSUSE Leap: 15.1
- Procps-Ng Project Procps-Ng: before 3.3.15 — fixed in 3.3.15
How to fix
Upgrade to a fixed version: Procps-Ng Project Procps-Ng 3.3.15. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00059.html
- http://seclists.org/oss-sec/2018/q2/122
- http://www.securityfocus.com/bid/104214
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1125
- https://lists.debian.org/debian-lts-announce/2018/05/msg00021.html
- https://usn.ubuntu.com/3658-1/
- https://usn.ubuntu.com/3658-3/
- https://www.debian.org/security/2018/dsa-4208
- https://www.qualys.com/2018/05/17/procps-ng-audit-report-advisory.txt
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00059.html
Get alerted when CVE-2018-1125 or the next vulnerability affects your stack