What’s Vulnerable › Vulnerabilities
CVE-2018-1126
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-23 · updated 2026-06-17
- Weakness: CWE-190
Description
procps-ng before version 3.3.15 is vulnerable to an incorrect integer size in proc/alloc.* leading to truncation/integer overflow issues. This flaw is related to CVE-2018-1124.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 17.10, 18.04
- Debian Linux: 7.0, 8.0, 9.0
- Procps-Ng Project Procps-Ng: before 3.3.15 — fixed in 3.3.15
- Red Hat Enterprise Linux: 7.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0, 7.5
- RedHat Enterprise Linux Server Aus: 6.6
- RedHat Enterprise Linux Server Tus: 6.6
- RedHat Enterprise Linux Workstation: 7.0
- Schneider Electric StruxureWare Data Center Expert: before 7.6.0 — fixed in 7.6.0
How to fix
Upgrade to a fixed version: Procps-Ng Project Procps-Ng 3.3.15; Schneider Electric StruxureWare Data Center Expert 7.6.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00058.html
- http://lists.opensuse.org/opensuse-security-announce/2019-10/msg00059.html
- http://seclists.org/oss-sec/2018/q2/122
- http://www.securityfocus.com/bid/104214
- http://www.securitytracker.com/id/1041057
- https://access.redhat.com/errata/RHSA-2018:1700
- https://access.redhat.com/errata/RHSA-2018:1777
- https://access.redhat.com/errata/RHSA-2018:1820
- https://access.redhat.com/errata/RHSA-2018:2267
- https://access.redhat.com/errata/RHSA-2018:2268
- https://access.redhat.com/errata/RHSA-2019:1944
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1126
Get alerted when CVE-2018-1126 or the next vulnerability affects your stack