What’s Vulnerable › Vulnerabilities
CVE-2018-1130
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-10 · updated 2026-06-17
- Weakness: CWE-476
Description
Linux kernel before version 4.16-rc7 is vulnerable to a null pointer dereference in dccp_write_xmit() function in net/dccp/output.c in that allows a local user to cause a denial of service by a number of certain crafted system calls.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04
- Debian Linux: 7.0, 8.0
- Linux kernel: before 4.16; 4.16-rc1, 4.16-rc2, 4.16-rc3, 4.16-rc4, 4.16-rc5, 4.16-rc6 — fixed in 4.16
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Linux kernel 4.16. Check the vendor advisory for mitigations.
References
- https://access.redhat.com/errata/RHSA-2018:1854
- https://access.redhat.com/errata/RHSA-2018:3083
- https://access.redhat.com/errata/RHSA-2018:3096
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1130
- https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=67f93df79aeefc3add4e4b31a752600f834236e2
- https://lists.debian.org/debian-lts-announce/2018/06/msg00000.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00015.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00016.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00020.html
- https://marc.info/?l=linux-netdev&m=152036596825220&w=2
- https://syzkaller.appspot.com/bug?id=833568de043e0909b2aeaef7be136db39d21ba94
- https://usn.ubuntu.com/3654-1/
Get alerted when CVE-2018-1130 or the next vulnerability affects your stack