What’s Vulnerable › Vulnerabilities
CVE-2018-11331
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-21 · updated 2026-06-17
- Weakness: CWE-434
Description
An issue was discovered in Pluck before 4.7.6. Remote PHP code execution is possible because the set of disallowed filetypes for uploads in missing some applicable ones such as .phtml and .htaccess.
Affected products
- pluck-cms: before 4.7.6 — fixed in 4.7.6
How to fix
Upgrade to a fixed version: pluck-cms 4.7.6. Check the vendor advisory for mitigations.
References
- https://github.com/pluck-cms/pluck/commit/8f6541e60c9435e82e9c531a20cb3c218d36976e
- https://github.com/pluck-cms/pluck/issues/58
- https://github.com/pluck-cms/pluck/commit/8f6541e60c9435e82e9c531a20cb3c218d36976e
- https://github.com/pluck-cms/pluck/issues/58
Get alerted when CVE-2018-11331 or the next vulnerability affects your stack