What’s Vulnerable › Vulnerabilities
CVE-2018-1139
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-22 · updated 2026-06-17
- Weakness: CWE-20
Description
A flaw was found in the way samba before 4.7.9 and 4.8.4 allowed the use of weak NTLMv1 authentication even when NTLMv1 was explicitly disabled. A man-in-the-middle attacker could use this flaw to read the credential and other details passed between the samba server and client.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Workstation: 7.0
- Samba: from 4.7.0 before 4.7.9; from 4.8.0 before 4.8.4 — fixed in 4.7.9, 4.8.4
How to fix
Upgrade to a fixed version: Samba 4.7.9, 4.8.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105084
- https://access.redhat.com/errata/RHSA-2018:2612
- https://access.redhat.com/errata/RHSA-2018:2613
- https://access.redhat.com/errata/RHSA-2018:3056
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1139
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20180814-0001/
- https://usn.ubuntu.com/3738-1/
- https://www.samba.org/samba/security/CVE-2018-1139.html
- http://www.securityfocus.com/bid/105084
- https://access.redhat.com/errata/RHSA-2018:2612
- https://access.redhat.com/errata/RHSA-2018:2613
Get alerted when CVE-2018-1139 or the next vulnerability affects your stack