What’s Vulnerable › Vulnerabilities
CVE-2018-1140
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 10.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-08-22 · updated 2026-06-17
- Weakness: CWE-20
Description
A missing input sanitization flaw was found in the implementation of LDP database used for the LDAP server. An attacker could use this flaw to cause a denial of service against a samba server, used as a Active Directory Domain Controller. All versions of Samba from 4.8.0 onwards are vulnerable
Affected products
- Samba: from 4.8.0 before 4.8.4 — fixed in 4.8.4
How to fix
Upgrade to a fixed version: Samba 4.8.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/105082
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1140
- https://bugzilla.samba.org/show_bug.cgi?id=13374
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20180814-0001/
- https://www.samba.org/samba/security/CVE-2018-1140.html
- http://www.securityfocus.com/bid/105082
- https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1140
- https://bugzilla.samba.org/show_bug.cgi?id=13374
- https://security.gentoo.org/glsa/202003-52
- https://security.netapp.com/advisory/ntap-20180814-0001/
- https://www.samba.org/samba/security/CVE-2018-1140.html
Get alerted when CVE-2018-1140 or the next vulnerability affects your stack