What’s Vulnerable › Vulnerabilities
CVE-2018-11407
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-13 · updated 2026-06-17
- Weakness: CWE-287
Description
An issue was discovered in the Ldap component in Symfony 2.8.x before 2.8.37, 3.3.x before 3.3.17, 3.4.x before 3.4.7, and 4.0.x before 4.0.7. It allows remote attackers to bypass authentication by logging in with a "null" password and valid username, which triggers an unauthenticated bind. NOTE: this issue exists because of an incomplete fix for CVE-2016-2403.
Affected products
- symfony: from 2.8.0 before 2.8.37; from 3.3.0 before 3.3.17; from 3.4.0 before 3.4.7; from 4.0.0 before 4.0.7 — fixed in 2.8.37, 3.3.17, 3.4.7, 4.0.7
How to fix
Upgrade to a fixed version: symfony 2.8.37, 3.3.17, 3.4.7, 4.0.7. Check the vendor advisory for mitigations.
References
- https://symfony.com/blog/cve-2018-11407-unauthorized-access-on-a-misconfigured-ldap-server-when-using-an-empty-password
- https://symfony.com/blog/cve-2018-11407-unauthorized-access-on-a-misconfigured-ldap-server-when-using-an-empty-password
Get alerted when CVE-2018-11407 or the next vulnerability affects your stack