What’s Vulnerable › Vulnerabilities
CVE-2018-1147
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-18 · updated 2026-06-17
- Weakness: CWE-79
Description
In Nessus before 7.1.0, a XSS vulnerability exists due to improper input validation. A remote authenticated attacker could create and upload a .nessus file, which may be viewed by an administrator allowing for the execution of arbitrary script code in a user's browser session. In other scenarios, XSS could also occur by altering variables from the Advanced Settings.
Affected products
- Tenable Nessus: before 7.1.0 — fixed in 7.1.0
How to fix
Upgrade to a fixed version: Tenable Nessus 7.1.0. Check the vendor advisory for mitigations.
References
- http://www.securitytracker.com/id/1040918
- https://www.tenable.com/security/tns-2018-05
- http://www.securitytracker.com/id/1040918
- https://www.tenable.com/security/tns-2018-05
Get alerted when CVE-2018-1147 or the next vulnerability affects your stack