What’s Vulnerable › Vulnerabilities
CVE-2018-11481
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-30 · updated 2026-06-17
- Weakness: CWE-20
Description
TP-LINK IPC TL-IPC223(P)-6, TL-IPC323K-D, TL-IPC325(KP)-*, and TL-IPC40A-4 devices allow authenticated remote code execution via crafted JSON data because /usr/lib/lua/luci/torchlight/validator.lua does not block various punctuation characters.
Affected products
- TP-Link Ipc Tl-Ipc223(P)-6 Firmware: before 1.0.21 — fixed in 1.0.21
- TP-Link Tl-Ipc323K-D Firmware: before 1.0.21 — fixed in 1.0.21
- TP-Link Tl-Ipc325(Kp) Firmware: before 1.0.21 — fixed in 1.0.21
- TP-Link Tl-Ipc40A-4 Firmware: before 1.0.21 — fixed in 1.0.21
How to fix
Upgrade to a fixed version: TP-Link Ipc Tl-Ipc223(P)-6 Firmware 1.0.21; TP-Link Tl-Ipc323K-D Firmware 1.0.21; TP-Link Tl-Ipc325(Kp) Firmware 1.0.21; TP-Link Tl-Ipc40A-4 Firmware 1.0.21. Check the vendor advisory for mitigations.
References
- https://github.com/yough3rt/IOT-pwn-for-fun/blob/master/TP-LINK-websys-Authenticated-RCE
- https://github.com/yough3rt/IOT-pwn-for-fun/blob/master/TP-LINK-websys-Authenticated-RCE
Get alerted when CVE-2018-11481 or the next vulnerability affects your stack