What’s Vulnerable › Vulnerabilities
CVE-2018-11506
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-05-28 · updated 2026-06-17
- Weakness: CWE-787
Description
The sr_do_ioctl function in drivers/scsi/sr_ioctl.c in the Linux kernel through 4.16.12 allows local users to cause a denial of service (stack-based buffer overflow) or possibly have unspecified other impact because sense buffers have different sizes at the CDROM layer and the SCSI layer, as demonstrated by a CDROMREADMODE2 ioctl call.
Affected products
- Canonical Ubuntu Linux: 16.04, 18.04
- Debian Linux: 8.0
- Linux kernel: from 4.11 before 4.14.45; from 4.15 before 4.16.13 — fixed in 4.14.45, 4.16.13
How to fix
Upgrade to a fixed version: Linux kernel 4.14.45, 4.16.13. Check the vendor advisory for mitigations.
References
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f7068114d45ec55996b9040e98111afa56e010fe
- https://access.redhat.com/errata/RHSA-2018:2948
- https://github.com/torvalds/linux/commit/f7068114d45ec55996b9040e98111afa56e010fe
- https://lists.debian.org/debian-lts-announce/2018/07/msg00015.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00016.html
- https://lists.debian.org/debian-lts-announce/2018/07/msg00020.html
- https://twitter.com/efrmv/status/1001574894273007616
- https://usn.ubuntu.com/3752-1/
- https://usn.ubuntu.com/3752-2/
- https://usn.ubuntu.com/3752-3/
- http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=f7068114d45ec55996b9040e98111afa56e010fe
- https://access.redhat.com/errata/RHSA-2018:2948
Get alerted when CVE-2018-11506 or the next vulnerability affects your stack