What’s Vulnerable › Vulnerabilities
CVE-2018-1156
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-08-23 · updated 2026-06-17
- Weakness: CWE-787
Description
Mikrotik RouterOS before 6.42.7 and 6.40.9 is vulnerable to stack buffer overflow through the license upgrade interface. This vulnerability could theoretically allow a remote authenticated attacker execute arbitrary code on the system.
Affected products
- MikroTik RouterOS: before 6.40.9; before 6.42.7 — fixed in 6.40.9, 6.42.7
How to fix
Upgrade to a fixed version: MikroTik RouterOS 6.40.9, 6.42.7. Check the vendor advisory for mitigations.
References
- https://mikrotik.com/download/changelogs
- https://mikrotik.com/download/changelogs/bugfix-release-tree
- https://www.tenable.com/security/research/tra-2018-21
- https://mikrotik.com/download/changelogs
- https://mikrotik.com/download/changelogs/bugfix-release-tree
- https://www.tenable.com/security/research/tra-2018-21
Get alerted when CVE-2018-1156 or the next vulnerability affects your stack