What’s Vulnerable › Vulnerabilities
CVE-2018-11574
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-14 · updated 2026-06-17
- Weakness: CWE-20
Description
Improper input validation together with an integer overflow in the EAP-TLS protocol implementation in PPPD may cause a crash, information disclosure, or authentication bypass. This implementation is distributed as a patch for PPPD 0.91, and includes the affected eap.c and eap-tls.c files. Configurations that use the `refuse-app` option are unaffected.
Affected products
- Canonical Ubuntu Linux: 14.04, 16.04, 18.04
- Point-To-Point Protocol Project Point-To-Point Protocol: before 2.4.9 — fixed in 2.4.9
How to fix
Upgrade to a fixed version: Point-To-Point Protocol Project Point-To-Point Protocol 2.4.9. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2018/06/11/1
- https://usn.ubuntu.com/3810-1/
- http://www.openwall.com/lists/oss-security/2018/06/11/1
- https://usn.ubuntu.com/3810-1/
Get alerted when CVE-2018-11574 or the next vulnerability affects your stack