What’s Vulnerable › Vulnerabilities
CVE-2018-11592
- Severity: medium (CVSS 5.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-125
Description
Espruino before 1.98 allows attackers to cause a denial of service (application crash) with a user crafted input file via an Out-of-bounds Read during syntax parsing in which certain height validation is missing in libs/graphics/jswrap_graphics.c.
Affected products
- Espruino: before 1.98 — fixed in 1.98
How to fix
Upgrade to a fixed version: Espruino 1.98. Check the vendor advisory for mitigations.
References
- https://github.com/espruino/Espruino/commit/8a44b04b584b3d3ab1cb68fed410f7ecb165e50e
- https://github.com/espruino/Espruino/files/2015630/test_0.txt
- https://github.com/espruino/Espruino/issues/1421
- https://github.com/espruino/Espruino/commit/8a44b04b584b3d3ab1cb68fed410f7ecb165e50e
- https://github.com/espruino/Espruino/files/2015630/test_0.txt
- https://github.com/espruino/Espruino/issues/1421
Get alerted when CVE-2018-11592 or the next vulnerability affects your stack