What’s Vulnerable › Vulnerabilities
CVE-2018-11593
- Severity: high (CVSS 7.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-787
Description
Espruino before 1.99 allows attackers to cause a denial of service (application crash) and potential Information Disclosure with a user crafted input file via a Buffer Overflow during syntax parsing because strncpy is misused in jslex.c.
Affected products
- Espruino: before 1.99 — fixed in 1.99
How to fix
Upgrade to a fixed version: Espruino 1.99. Check the vendor advisory for mitigations.
References
- https://github.com/espruino/Espruino/commit/bed844f109b6c222816740555068de2e101e8018
- https://github.com/espruino/Espruino/files/2019228/eh_0.txt
- https://github.com/espruino/Espruino/issues/1426
- https://github.com/espruino/Espruino/commit/bed844f109b6c222816740555068de2e101e8018
- https://github.com/espruino/Espruino/files/2019228/eh_0.txt
- https://github.com/espruino/Espruino/issues/1426
Get alerted when CVE-2018-11593 or the next vulnerability affects your stack