What’s Vulnerable › Vulnerabilities
CVE-2018-11595
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-119
Description
Espruino before 1.99 allows attackers to cause a denial of service (application crash) and a potential Escalation of Privileges with a user crafted input file via a Buffer Overflow during syntax parsing, because strncat is misused.
Affected products
- Espruino: before 1.99 — fixed in 1.99
How to fix
Upgrade to a fixed version: Espruino 1.99. Check the vendor advisory for mitigations.
References
- https://github.com/espruino/Espruino/commit/0a7619875bf79877907205f6bee08465b89ff10b
- https://github.com/espruino/Espruino/files/2019210/test_0.txt
- https://github.com/espruino/Espruino/files/2019216/test_2.txt
- https://github.com/espruino/Espruino/files/2019220/test_4.txt
- https://github.com/espruino/Espruino/issues/1425
- https://github.com/espruino/Espruino/commit/0a7619875bf79877907205f6bee08465b89ff10b
- https://github.com/espruino/Espruino/files/2019210/test_0.txt
- https://github.com/espruino/Espruino/files/2019216/test_2.txt
- https://github.com/espruino/Espruino/files/2019220/test_4.txt
- https://github.com/espruino/Espruino/issues/1425
Get alerted when CVE-2018-11595 or the next vulnerability affects your stack