What’s Vulnerable › Vulnerabilities
CVE-2018-11598
- Severity: high (CVSS 7.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2018-05-31 · updated 2026-06-17
- Weakness: CWE-125
Description
Espruino before 1.99 allows attackers to cause a denial of service (application crash) and a potential Information Disclosure with user crafted input files via a Buffer Overflow or Out-of-bounds Read during syntax parsing of certain for loops in jsparse.c.
Affected products
- Espruino: before 1.99 — fixed in 1.99
How to fix
Upgrade to a fixed version: Espruino 1.99. Check the vendor advisory for mitigations.
References
- https://github.com/espruino/Espruino/commit/bf4416ab9129ee3afd56739ea4e3cd0da5484b6b
- https://github.com/espruino/Espruino/files/2025956/test_0.txt
- https://github.com/espruino/Espruino/files/2025963/test_1.txt
- https://github.com/espruino/Espruino/files/2025968/test_2.txt
- https://github.com/espruino/Espruino/issues/1437
- https://github.com/espruino/Espruino/commit/bf4416ab9129ee3afd56739ea4e3cd0da5484b6b
- https://github.com/espruino/Espruino/files/2025956/test_0.txt
- https://github.com/espruino/Espruino/files/2025963/test_1.txt
- https://github.com/espruino/Espruino/files/2025968/test_2.txt
- https://github.com/espruino/Espruino/issues/1437
Get alerted when CVE-2018-11598 or the next vulnerability affects your stack