What’s Vulnerable › Vulnerabilities

CVE-2018-1160

Description

Netatalk before 3.1.12 is vulnerable to an out of bounds write in dsi_opensess.c. This is due to lack of bounds checking on attacker controlled data. A remote unauthenticated attacker can leverage this vulnerability to achieve arbitrary code execution.

Affected products

How to fix

Upgrade to a fixed version: Netatalk 3.1.12; Synology DiskStation Manager 5.2-5967-9, 6.1.7-15284-3, 6.2.1-23824-4; Synology Router Manager (SRM) 1.2-7742-5. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-1160 or the next vulnerability affects your stack