What’s Vulnerable › Vulnerabilities
CVE-2018-11650
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-01 · updated 2026-06-17
- Weakness: CWE-79
Description
Graylog before v2.4.4 has an XSS security issue with unescaped text in notifications, related to toastr and util/UserNotification.js.
Affected products
- graylog2-server: before 2.4.4 — fixed in 2.4.4
How to fix
Upgrade to a fixed version: graylog2-server 2.4.4. Check the vendor advisory for mitigations.
References
- https://github.com/Graylog2/graylog2-server/pull/4727
- https://www.graylog.org/post/announcing-graylog-v2-4-4
- https://github.com/Graylog2/graylog2-server/pull/4727
- https://www.graylog.org/post/announcing-graylog-v2-4-4
Get alerted when CVE-2018-11650 or the next vulnerability affects your stack