What’s Vulnerable › Vulnerabilities
CVE-2018-11710
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-04 · updated 2026-06-17
- Weakness: CWE-787
Description
soundlib/pattern.h in libopenmpt before 0.3.9 allows remote attackers to cause a denial of service (application crash) or possibly have unspecified other impact via a crafted AMS file because of an invalid write near address 0 in an out-of-memory situation.
Affected products
- Openmpt Libopenmpt: before 0.3.9 — fixed in 0.3.9
How to fix
Upgrade to a fixed version: Openmpt Libopenmpt 0.3.9. Check the vendor advisory for mitigations.
References
- https://lib.openmpt.org/libopenmpt/2018/04/29/security-updates-0.3.9-0.2-beta32-0.2.7561-beta20.5-p9-0.2.7386-beta20.3-p12/
- https://source.openmpt.org/browse/openmpt/trunk/?op=revision&rev=10149&peg=10150
- https://lib.openmpt.org/libopenmpt/2018/04/29/security-updates-0.3.9-0.2-beta32-0.2.7561-beta20.5-p9-0.2.7386-beta20.3-p12/
- https://source.openmpt.org/browse/openmpt/trunk/?op=revision&rev=10149&peg=10150
Get alerted when CVE-2018-11710 or the next vulnerability affects your stack