What’s Vulnerable › Vulnerabilities
CVE-2018-11713
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-06-04 · updated 2026-06-17
Description
WebCore/platform/network/soup/SocketStreamHandleImplSoup.cpp in the libsoup network backend of WebKit, as used in WebKitGTK+ prior to version 2.20.0 or without libsoup 2.62.0, unexpectedly failed to use system proxy settings for WebSocket connections. As a result, users could be deanonymized by crafted web sites via a WebSocket connection.
Affected products
- GNOME libsoup: before 2.62.0 — fixed in 2.62.0
- Webkitgtk+: before 2.20.0 — fixed in 2.20.0
How to fix
Upgrade to a fixed version: GNOME libsoup 2.62.0; Webkitgtk+ 2.20.0. Check the vendor advisory for mitigations.
References
- https://bugs.webkit.org/show_bug.cgi?id=126384
- https://security.gentoo.org/glsa/201808-04
- https://trac.webkit.org/changeset/228088/webkit
- https://bugs.webkit.org/show_bug.cgi?id=126384
- https://security.gentoo.org/glsa/201808-04
- https://trac.webkit.org/changeset/228088/webkit
Get alerted when CVE-2018-11713 or the next vulnerability affects your stack