What’s Vulnerable › Vulnerabilities
CVE-2018-11747
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-21 · updated 2026-06-17
- Weakness: CWE-295
Description
Previously, Puppet Discovery was shipped with a default generated TLS certificate in the nginx container. In version 1.4.0, a unique certificate will be generated on installation or the user will be able to provide their own TLS certificate for ingress.
Affected products
- Puppet Discovery: before 1.4.0 — fixed in 1.4.0
How to fix
Upgrade to a fixed version: Puppet Discovery 1.4.0. Check the vendor advisory for mitigations.
References
- https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995ec908ce7624d26%40%3Ccommits.pulsar.apache.org%3E
- https://puppet.com/security/cve/CVE-2018-11747
- https://lists.apache.org/thread.html/rd0e44e8ef71eeaaa3cf3d1b8b41eb25894372e2995ec908ce7624d26%40%3Ccommits.pulsar.apache.org%3E
- https://puppet.com/security/cve/CVE-2018-11747
Get alerted when CVE-2018-11747 or the next vulnerability affects your stack