What’s Vulnerable › Vulnerabilities
CVE-2018-11748
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-10-02 · updated 2026-06-17
- Weakness: CWE-522
Description
Previous releases of the Puppet device_manager module creates configuration files containing credentials that are world readable. This issue has been resolved as of device_manager 2.7.0.
Affected products
- Puppet Device Manager: before 2.7.0 — fixed in 2.7.0
How to fix
Upgrade to a fixed version: Puppet Device Manager 2.7.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-11748 or the next vulnerability affects your stack