What’s Vulnerable › Vulnerabilities
CVE-2018-11781
- Severity: high (CVSS 7.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2018-09-17 · updated 2026-06-17
- Weakness: CWE-94
Description
Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.
Affected products
- Apache Software Foundation Apache SpamAssassin: before 3.4.2 — fixed in 3.4.2
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04
- Debian Linux: 8.0
- RedHat Enterprise Linux Desktop: 7.0
- RedHat Enterprise Linux Server: 7.0
- RedHat Enterprise Linux Server Eus: 7.5
- RedHat Enterprise Linux Workstation: 7.0
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache SpamAssassin 3.4.2. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00002.html
- https://access.redhat.com/errata/RHSA-2018:2916
- https://lists.apache.org/thread.html/7f6a16bc0fd0fd5e67c7fd95bd655069a2ac7d1f88e42d3c853e601c%40%3Cannounce.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2018/11/msg00016.html
- https://security.gentoo.org/glsa/201812-07
- https://usn.ubuntu.com/3811-1/
- https://usn.ubuntu.com/3811-3/
- http://lists.opensuse.org/opensuse-security-announce/2019-08/msg00002.html
- https://access.redhat.com/errata/RHSA-2018:2916
- https://lists.apache.org/thread.html/7f6a16bc0fd0fd5e67c7fd95bd655069a2ac7d1f88e42d3c853e601c%40%3Cannounce.apache.org%3E
- https://lists.debian.org/debian-lts-announce/2018/11/msg00016.html
- https://security.gentoo.org/glsa/201812-07
Get alerted when CVE-2018-11781 or the next vulnerability affects your stack