What’s Vulnerable › Vulnerabilities
CVE-2018-11793
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-03-05 · updated 2026-06-17
- Weakness: CWE-119
Description
When parsing a JSON payload with deeply nested JSON structures, the parser in Apache Mesos versions pre-1.4.x, 1.4.0 to 1.4.2, 1.5.0 to 1.5.1, 1.6.0 to 1.6.1, and 1.7.0 might overflow the stack due to unbounded recursion. A malicious actor can therefore cause a denial of service of Mesos masters rendering the Mesos-controlled cluster inoperable.
Affected products
- Apache Software Foundation Apache Mesos: from 1.4.0 before 1.4.3; from 1.5.0 before 1.5.2; from 1.6.0 before 1.6.2; from 1.7.0 before 1.7.1; 1.4.0-rc1, 1.4.0-rc2, 1.4.0-rc3, 1.4.0-rc4, 1.4.0-rc5, 1.8.0-dev — fixed in 1.4.3, 1.5.2, 1.6.2, 1.7.1
How to fix
Upgrade to a fixed version: Apache Software Foundation Apache Mesos 1.4.3, 1.5.2, 1.6.2, 1.7.1. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/107281
- https://lists.apache.org/thread.html/9be975c53e5ad612c7e0af39f5b88837fbfbc32108e587d3d8499844%40%3Cdev.mesos.apache.org%3E
- http://www.securityfocus.com/bid/107281
- https://lists.apache.org/thread.html/9be975c53e5ad612c7e0af39f5b88837fbfbc32108e587d3d8499844%40%3Cdev.mesos.apache.org%3E
Get alerted when CVE-2018-11793 or the next vulnerability affects your stack